Cash Withdrawal Issue
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 13:00 EST
Investigating
We understand some Stashers may not be able to withdraw cash from their brokerage accounts. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted Jan 24, 2023 - 11:22 EST
This incident affected: Money & Transfers.