Issue loading Invest screen in Stash apps
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Sep 29, 2021 - 14:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2021 - 13:32 EDT
Investigating
Some users are currently experiencing an issue loading Stash. We are currently working on a resolution and will update you as soon as it’s fixed.
Posted Sep 29, 2021 - 13:27 EDT
This incident affected: Apps (Android App, iOS App, stash.com).