Issues with the app

Incident Report for Stash

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 13:22 EST

Update

We are continuing to investigate this issue.
Posted Jan 05, 2026 - 13:21 EST

Update

We are continuing to investigate this issue.
Posted Jan 05, 2026 - 12:44 EST

Update

We are continuing to investigate this issue.
Posted Jan 05, 2026 - 12:04 EST

Investigating

We understand you might be experiencing issues with the Stash app. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Jan 05, 2026 - 12:04 EST
This incident affected: Money & Transfers and External Bank Linking.