Bank balances only reflected in bank home
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 13:59 EDT
Update
We are continuing to investigate this issue.
Posted Sep 14, 2022 - 13:59 EDT
Investigating
We understand you may not be able to view your most recent bank balance on Stash home. However, you can still view it on Bank home. We are actively working to resolve the issue and apologize for any inconvenience.
Posted Sep 14, 2022 - 13:21 EDT
This incident affected: Banking¹.