Issues with the app
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 14:24 EST
Identified
We understand you might be experiencing issues with the Stash app. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Nov 14, 2022 - 13:00 EST
This incident affected: Apps (Android App).