Equities trades update.
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 12:47 EDT
Update
We are continuing to investigate this issue.
Posted Oct 03, 2022 - 11:38 EDT
Investigating
Equities trades have not yet been processed today due to an issue. However, you can still place new order instructions within the app or cancel any pending orders. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted Oct 03, 2022 - 11:33 EDT
This incident affected: Investing.