Cloudflare global outage

Incident Report for Stash

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:56 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:36 EST

Monitoring

A fix has been implemented by Cloudflare, and we believe the incident is now resolved.
We are continuing to monitor to ensure all connectivity and services are fully restored.
Posted Nov 18, 2025 - 10:29 EST

Identified

We are currently experiencing intermittent connectivity issues due to a Cloudflare global outage https://www.cloudflarestatus.com/
.
Our team is monitoring the situation closely and will provide updates as Cloudflare releases more information.
Posted Nov 18, 2025 - 07:38 EST
This incident affected: Apps (Android App, iOS App, stash.com), Communication (Push Notifications, Email Support, Phone Support), and Investing, Banking¹, Money & Transfers, Stock-Back® Card¹, External Bank Linking, Log In.