Phone System Outage
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 17:09 EDT
Update
We are continuing to investigate this issue.
Posted Oct 13, 2021 - 13:36 EDT
Investigating
Investigating - We're currently experiencing a phone system outage at our customer service center. We're actively working to resolve this issue and apologize for any inconvenience. If you need help with your Stash account, please refer to ask.stash.com or email support@stash.com.
Posted Oct 13, 2021 - 13:34 EDT
This incident affected: Communication (Phone Support).