Issues with Transfers and the Stock-Back Card
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 18:46 EDT
Investigating
We understand a few Stashers are having issues with banking—such as viewing recent transfers in portfolio activity, bank transactions, and issues with the Stock-Back® Card. Sit tight—we’re actively working to resolve the issue.
Posted Mar 24, 2023 - 14:50 EDT
This incident affected: Banking¹ and Money & Transfers.