Issue with linking bank accounts

Incident Report for Stash

Resolved

This incident has been resolved.
Posted Nov 06, 2023 - 18:35 EST

Update

The error is no longer occurring, issue is now resolved.
Posted Nov 06, 2023 - 18:33 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2023 - 17:17 EST

Identified

We understand you might be experiencing issues with linking your external bank to Stash. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Nov 06, 2023 - 16:08 EST
This incident affected: External Bank Linking.