We are continuing to monitor for any further issues.
Posted Aug 23, 2024 - 01:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2024 - 01:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 23, 2024 - 00:16 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 22, 2024 - 23:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2024 - 23:54 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 22:58 EDT
Identified
We understand you might be experiencing issues with the Stash app. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Aug 22, 2024 - 22:56 EDT
This incident affected: Apps (Android App, iOS App, stash.com), Communication (Push Notifications, Email Support, Phone Support), and Investing, Banking¹, Money & Transfers, Stock-Back® Card¹, External Bank Linking, Log In.