Transfer Processing Delays

Incident Report for Stash

Resolved

This incident has been resolved.
Posted Jul 29, 2022 - 11:10 EDT

Investigating

We understand you might be experiencing issues with viewing recent transfers in your Stash portfolio activity and/or bank transactions. Don’t worry—your transfers have been made, and will be reflected in your Stash account balances by the end of the day. We are actively working to resolve the issue and apologize for any inconvenience.
Posted Jul 29, 2022 - 10:55 EDT
This incident affected: Money & Transfers.