Increased load times and time-outs
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 15:26 EDT
Investigating
Our app is experiencing an outage with slow load times and time-outs. We’re actively working to resolve the issue as quickly as possible.
Posted Jun 09, 2021 - 15:16 EDT
This incident affected: Investing, Banking¹, Money & Transfers, External Bank Linking, and Log In.