Issue with Banking Statements
Incident Report for Stash
Resolved
This incident has been resolved.
Posted May 17, 2023 - 11:16 EDT
Investigating
We understand some Stashers are having issues retrieving their banking statements. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted May 11, 2023 - 14:29 EDT
This incident affected: Banking¹.