Issues with the app
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Feb 06, 2025 - 14:01 EST
Investigating
We understand you might be experiencing issues with the Stash app. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Feb 06, 2025 - 13:30 EST
This incident affected: Apps (Android App, iOS App, stash.com).