Issue with Money Transfers
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 11:05 EST
Investigating
We understand some Stashers are having issues with transfers. Sit tight—we’re actively working to resolve the issue.
Posted Mar 10, 2023 - 10:44 EST
This incident affected: Money & Transfers.