Stock-Back® Card issues
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 19:48 EDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 19:31 EDT
Investigating
We understand you might be experiencing issues with your Stock-Back® Card.¹ Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Sep 18, 2023 - 19:29 EDT
This incident affected: Banking¹, Money & Transfers, and Stock-Back® Card¹.