The issue that delayed account activity beginning Wednesday, July 29 has been addressed, and activity is processing normally. Our teams are continuing to monitor.
A small number of accounts are still under review. Some customers may continue to see delayed or incorrect information until that review is complete.
We expect to share our next update tomorrow morning.
Posted Jul 30, 2026 - 17:43 EDT
Update
Our teams are continuing to work through account activity affected on Wednesday, July 29. New activity is processing normally.
Customers affected during that period may still see delayed or incorrect information in the app while this work continues.
We will share another update later today.
Posted Jul 30, 2026 - 16:12 EDT
Identified
We have identified the cause of the issue that delayed some account activity beginning around 12 p.m. ET on Wednesday, July 29. New activity is processing normally.
We are continuing to work through account activity from that period. Some customers may still see delayed or incorrect information in the app while that work continues.
We will share another update as we have more information.
Posted Jul 30, 2026 - 13:58 EDT
Update
Our teams are continuing to review affected accounts and reconcile activity that did not go through.
New activity is processing normally. Customers affected earlier may still see delayed or incorrect account information while this review continues.
We will share another update as we have more information.
Posted Jul 30, 2026 - 12:33 EDT
Update
An issue beginning around 12 p.m. ET on Wednesday, July 29, delayed some account activity. Some customers may have seen delayed account setup and incorrect cash balances displayed in the app.
New activity is now processing normally. We are reviewing affected accounts and reconciling anything that did not go through.
We will share another update as we have more information.
Posted Jul 30, 2026 - 11:25 EDT
Investigating
We understand you might be experiencing issues with the Stash app. Sit tight—we’re actively working to resolve the issue and apologize for any inconvenience.
Posted Jul 30, 2026 - 10:21 EDT
This incident affected: Apps (Android App, iOS App, stash.com) and Investing, Money & Transfers, External Bank Linking.