Email Outage
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 13:28 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 26, 2024 - 11:52 EST
Investigating
We are currently investigating this issue.
Posted Nov 26, 2024 - 11:42 EST
This incident affected: Communication (Email Support).