Bank Home Issue
Incident Report for Stash
Resolved
This incident has been resolved.
Posted May 20, 2022 - 14:31 EDT
Investigating
We understand some Stashers are having issues with viewing updates on their desktop Bank home screen. However, you should still be able to transfer funds as usual. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted May 20, 2022 - 14:09 EDT
This incident affected: Banking¹ and External Bank Linking.