Bank Home Issue for Select Users
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Oct 05, 2022 - 13:47 EDT
Investigating
We understand some Stashers might be experiencing issues with Bank Home. However, trades and investing have not been impacted. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted Oct 05, 2022 - 13:47 EDT
This incident affected: Banking¹.