Partial Outage
Incident Report for Stash
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 07:31 EDT
Investigating
We understand some Stashers may be experiencing slow load times and time-outs. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted Jun 10, 2022 - 00:53 EDT
This incident affected: Investing, Banking¹, and Stock-Back® Card¹.